NVIDIA-logo

Want to use Nvidia ShadowPlay on your Laptop? Here’s How.

When Nvidia dropped the news that they would supplement their GeForce Experience software with streaming and capture capabilities I wondered if it would be able to compete with the Fraps & Bandicams of the world. ShadowPlay by far is the best and easiest way to capture gameplay that you could ever use….if you have a desktop PC that is.

[y=Lyy3ZijLJ0s height=400]

Those of us who game on our laptops (yes I know get a desktop) we were sad to see that this option wasn’t available to us when we downloaded the new drivers. I can see why Nvidia would hold off on pushing the feature through to mobile computers, excess heat and less than optimal GPUs already kill most gaming performance. Capturing would just make it less efficient. But for those of you that want to try it for yourselves follow these instructions and you can enable ShadowPlay on your laptops.

Find the Geforce Experience executable first.

“C:\Program Files (x86)\NVIDIA Corporation\NVIDIA GeForce Experience\GFExperience.exe”

Right-click on the exe file and choose “create shortcut”. Being in the Program Files folder, it will likely complain it can’t create files there and ask if the desktop is ok – say yes. If not, the shortcut will be created in the same folder and you can move it to the desktop, or any location of your choice.

Then, right-click the shortcut, choose Properties, and in the Target field you have

“C:\Program Files (x86)\NVIDIA Corporation\NVIDIA GeForce Experience\GFExperience.exe”

Change this to

“C:\Program Files (x86)\NVIDIA Corporation\NVIDIA GeForce Experience\GFExperience.exe” -shadowplay

then Apply/OK.

Run the shortcut, you will get geforce experience starting up with an extra control window for ShadowPlay. Flip the switch on the left to enable it – for me this caused the screen to flicker a few times (probably installing some extra video filter driver, who knows)

Thanks to the folks over in the Republic of Gaming/ASUS forums for sharing this awesome information and helping all of us use this really cool tech. I will post some thoughts on the software in a later post.

Check it out, let us know what you think and also be careful as it’s use really isn’t recommended on laptops as of yet. So be careful out there.

Also share your thoughts on how you like it below in the comments!

*UPDATE* There are some folks who are having some issue and don’t believe that it works. Here is a quick video showing that it actually is running. Please remember folks things change over time with updates and patches. Thanks!

[y=VZIQdv6ITG0 height=400]

Kahlief Adams

Kahlief was born and raised in the Bronx, New York. As an avid technophile and lover of all things video games. He set his career path in the direction of a life making games until he found out his arch nemesis, β€œMath,” had other plans in store. So instead of making the next Tetris he found himself writing and talking about games on his website The Spawn Point Blog and Spawn On Me. Check out what I'm blabbering about over @kahjahkins on Twitter. PSN = KAHJAH1 XBL=KAHJAHKINS

80 Comments
  • Raf
    Reply

    I did this, shadowplay is running but I dont have shadowplay’s icon in game so I cannot record. Game launched in fullscreen on windows7 and gtx660m

    October 30, 2013 at 1:30 pm
    • thespawnpointblog
      Reply

      That is pretty weird, maybe a restart will get it back, also make sure the switch is in the on position. I thought I had mine running when it wasn’t. Plus it’s still in Beta so I’m expecting bugginess. Let us know if you get it back up and running.

      October 30, 2013 at 1:36 pm
      • Nathan Draiman
        Reply

        i have the same issue, did several restarts to no avail

        November 15, 2013 at 7:31 am
        • HotSace
          Reply

          Same issue

          November 14, 2015 at 6:43 pm
  • Yuness L
    Reply

    Can anyone tell me what wrong, i get to the part when you need to change the target to this:
    β€œC:Program Files (x86)NVIDIA CorporationNVIDIA GeForce ExperienceGFExperience.exe” -shadowplay

    however i get this error code:

    The name ‘”c:/program’ specified in the target box is not valid. Make sure that the path and filename are correct.

    November 9, 2013 at 5:27 pm
    • anon
      Reply

      space

      November 10, 2013 at 6:55 pm
    • thespawnpointblog
      Reply

      Honestly I’m not sure why it’s not working, I copied the path and it worked for me.

      November 10, 2013 at 7:01 pm
    • Uri
      Reply

      I had to delete the ” s and type those in and that fixed that issue for me.

      November 27, 2015 at 5:57 pm
    • slash is missing

      February 27, 2017 at 9:49 am
    • luanchblox15
      Reply

      you need to capitalize the S in shadowplay in order to get it working.

      April 8, 2017 at 5:50 pm
  • Matthew Sanchez
    Reply

    Okay so It’s working for me now and the Shadowplay Window pops up. However, I still can’t get it to record my gameplay. Is it for online only or can I use it for the story mode on a game?

    November 14, 2013 at 3:20 pm
    • thespawnpointblog
      Reply

      You should be able to use it for any game running on your system, make sure you check out what buttons are set to capture the gameplay in the settings and that the switch in the Shadowplay is in the “on” position. You should be good.

      Thanks so much for commenting Matt

      November 14, 2013 at 3:25 pm
      • ShitsBrokenYo
        Reply

        It doesn’t work. I bet you didn’t test this before you copy/pasted it.

        November 18, 2013 at 10:07 pm
        • thespawnpointblog
          Reply

          As of this article’s posting it was tested and working, not sure if they’ve updated and killed the feature. You could be doing something wrong or they could have patched it out. Please check before posting that I didn’t do the research.

          November 19, 2013 at 12:01 pm
          • ShitsBrokenYo

            I’m sure you did your research. That’s why I can find so many comments saying it’s working (lol not even one), and nobody is having any problems (literally every comment on here).

            So congratulations; you found an excellent way for people to open a user interface with exactly zero functionality.

            I dare your lazy ass to record a video on your laptop using ShadowPlay and post a link.

            November 19, 2013 at 3:22 pm
          • thespawnpointblog

            Here ya go, I just made a quick video for you and other folks that don’t believe that it is working. The audio is a little low because I’m at work but you can clearly see that it is working.

            Thanks for the discussion, I would suggest that you check your settings or maybe try re-installing it exactly the way it is described in the post. Also check to see if Nvidia might have patche the function out.

            http://youtu.be/VZIQdv6ITG0

            November 19, 2013 at 4:18 pm
          • thespawnpointblog

            Just for you sir.

            November 19, 2013 at 4:31 pm
          • Avegaard

            This is great, thanks alot for posting this (it’s working) πŸ™‚ Stop being a douche Shit, “If you ain’t got nothing nice to say, then don’t say nothing”.

            November 20, 2013 at 4:27 am
          • Guythatismakingfunoyou

            Your an asshole

            February 1, 2014 at 11:38 pm
  • Norwegian viking
    Reply

    Doesn’t work, why would i copy and paste the same thing? “C:Program Files (x86)NVIDIA CorporationNVIDIA GeForce ExperienceGFExperience.exe” also i get this message if i write “-shadowplay” in the end ;”The name ‘”c:/program’ specified in the target box is not valid. Make sure that the path and filename are correct” . help please

    November 15, 2013 at 8:32 pm
    • Cullen
      Reply

      make sure to put a space between the quotation marks or you will get that error

      February 1, 2014 at 12:53 pm
    • asdf
      Reply

      The comment below didn’t solve a problem, it should be:
      “C:Program Files (x86)NVIDIA CorporationNVIDIA GeForce ExperienceGFExperience.exe” -shadowplay

      What you had there: “C:Program Files (x86)NVIDIA CorporationNVIDIA GeForce ExperienceGFExperience.exe” also i get this message if i write “-shadowplay”

      You see? an extra ” at the end of shadowplay, you don’t need that

      April 9, 2014 at 5:48 pm
  • Austin BriceΓ±o
    Reply

    so i got shadow play to work but it will not record! i made shore that the game is optimized in GeForce experience and i tried launching the games in GeForce experience. is there something i forget to do? i have a lenovo y510p if that makes a different

    November 17, 2013 at 6:34 pm
    • Aaron Michael B
      Reply

      I have the Lenovo Y500 x2-750m, I’m going to record CS:GO on max settings. I’ll let you know if it works or not. πŸ˜€

      November 20, 2013 at 1:47 pm
      • TilledCone
        Reply

        did your lenovo come with the second card or did you buy it? and if you bought it, where did you get a card that will fit in the UltraBay?

        December 18, 2013 at 1:58 pm
  • thespawnpointblog
    Reply

    Thanks for posting Mads, I will check and see if an update killed the feature but mine is still working.

    November 19, 2013 at 12:02 pm
  • graidstin
    Reply

    Just did it and it worked perfectly fine. I’m on an ASUS G750JX

    November 19, 2013 at 5:28 pm
    • thespawnpointblog
      Reply

      Thanks so much for your response!!

      November 20, 2013 at 10:50 am
  • Avegaard
    Reply

    Hey guys, i had the problem with the shortcut not accepting ‘”C:Program Files (x86)NVIDIA CorporationNVIDIA GeForce ExperienceGFExperience.exe”-shadowplay’. Turns out however, that if i paste the address into Run instead, it works just fine πŸ™‚

    November 20, 2013 at 4:23 am
    • thespawnpointblog
      Reply

      Thank you for posting and letting folks know that it is working.

      November 20, 2013 at 10:50 am
  • BrazGoalie
    Reply

    Works Flawlessly
    did it with the new update they brought out and it works like a charm

    December 17, 2013 at 3:28 pm
    • thespawnpointblog
      Reply

      So happy to hear it, I did a jump for joy once I saw it worked for me. Spread the word, and share the site if you like what you’ve seen.

      December 17, 2013 at 7:31 pm
  • thespawnpointblog
    Reply

    Hey Sloth, great video and can I rent your voice for late night phone calls? Just kidding. Would you mind if I embed this into the article? I think it would be a great addition to the story?

    December 17, 2013 at 7:33 pm
    • Slothability
      Reply

      Haha depends on who i’ll be talking to xD. Feel free to embed the video, I hope it helps some people out! Thanks again for the info!

      December 18, 2013 at 2:24 pm
  • Bournestorm
    Reply

    For some reason I’m in the group of people having trouble getting it to work

    I’ve followed the directions exactly (Create shortcut, add *space* -shadowplay, apply and ok, launch, flip switch, change settings to whatever suits me, launch game) However I’m not seeing the circular symbol indicating that Shadowplay is on inside any of my games

    Is it perhaps because all my games run through Steam?

    December 18, 2013 at 2:10 pm
    • Boredguy
      Reply

      Hey! I had the same problem. I installed the newest drivers 332.21 from nvidia site and now i can see the icon ingame, but i have a red line on top of it and i cant use it.

      So see if ur one works πŸ™‚ Cheers

      January 13, 2014 at 9:55 am
  • thespawnpointblog
    Reply

    HA!! glad we could help

    December 19, 2013 at 10:21 am
  • thespawnpointblog
    Reply

    I can look around and see if there is anything I can find to help. Thanks so much for stopping in and reading our story.

    December 19, 2013 at 10:22 am
  • mema tron
    Reply

    I got it to work by pasting it WITHOUT the quotes. That will work

    January 9, 2014 at 10:54 am
    • thespawnpointblog
      Reply

      Just want to check, is it working with the newest version as well?

      January 9, 2014 at 12:43 pm
      • Philly Tran
        Reply

        The ShadowPlay window pops up, but the switch refuses to turn on. Click it, and it will go “Activating ShadowPlay”, but the switch will go back to disabled. I am using Geforce Driver 334.89, not yet updated to 335.23.

        March 28, 2014 at 11:31 pm
        • Des
          Reply

          Hi, did you make it work somehow?

          March 21, 2016 at 9:31 am
  • Vivek Rana
    Reply

    It wont enable for me

    January 11, 2014 at 2:44 pm
  • AP 
    Reply

    AWESOME <3 thanks so muuch! works perfectly for me Lenovo Y580 with GTX660m .

    January 13, 2014 at 7:33 pm
  • Slothability
    Reply

    Just wanted to stop by again and say that with the latest update and drivers, this still works for me and they finally added an option to record at 30 FPS! Cheers.

    March 2, 2014 at 12:17 am
  • gaurav sharama
    Reply

    thanks guys!! working great for me in my 610m card… tell me if anything is there like this . i never thought that it would run on my lappy

    March 20, 2014 at 12:47 pm
    • darts100
      Reply

      So you managed to get it working on a GT610M? I’m trying to use a GT630M and I get the red line through the symbol in-game when I try to record. But you can record in-game fine?

      I assumed it was due to my card not being a GTX card, but if you can do it with a 610 then there might still be hope :3

      April 2, 2014 at 1:07 am
  • Ober
    Reply

    I have it opened, but I can’t seem to record. Whenever I try to manual record, I hit the hotkeys and there’s a slight hiccup in the game, but the icon in the bottom right has a red line through it.

    March 24, 2014 at 1:53 am
    • KrazyStew
      Reply

      Same, I’ve been trying everything and I have a GTX 770M, no one seems to be giving me any valuable answers here

      April 13, 2014 at 3:21 pm
  • Suchir Kavi
    Reply

    It works on my Y410p.

    March 25, 2014 at 5:03 pm
  • SoulViking
    Reply

    I was getting the error that most were getting and it was because I was just putting -shadowplay at the end and hitting apply. You have to leave the address the way it is, put a space after the end of the whole line and then put “-shadowplay” WITH quotes. I exited Nvidia while I did it too, maybe that made a difference.

    April 3, 2014 at 6:31 pm
  • darts100
    Reply

    something you should mention is that your card must feature a Kepler or above chip.

    One way to check this is on Wikipedia, simply google “GeForce series”, once on the wiki page, go to ‘products’ then look for your card, make sure the code name starts with ‘GK’ or ‘GM’, if it does then you’re good, if it starts with ‘GF’ that means it’s a Fermi chip and won’t work with SP.

    For example, my card is a GT630M, it’s code name is ‘GF108’, if I try and use ShadowPlay, the icon just has a red line through it.

    However, the GT640M is ‘GK107’, so it will work with ShadowPlay.

    April 4, 2014 at 9:20 am
  • bomej
    Reply

    When i’m flipping the switch, it says “Activating Shadowplay” and when activating is done, switch is going back to “off” position. GT640M.
    2 Months ago that was working, now not, could any1 help?

    April 10, 2014 at 8:43 am
    • Bomej
      Reply

      Sorry, its GT740M

      April 10, 2014 at 8:51 am
  • Adam Goyer
    Reply

    Thank You! Very Cool/

    April 29, 2014 at 10:11 pm
  • Charles :D
    Reply

    Works to on the desktop πŸ˜€
    I have Gt 610 πŸ˜€

    May 23, 2014 at 2:53 am
    • Darlanio
      Reply

      How were you able to get the “Allow recording of Desktop” marked aswell?

      October 14, 2014 at 3:50 am
  • Shaun Oligo
    Reply

    This is AWESOME! Thanks a lot dude! Legend!

    May 31, 2014 at 4:42 am
    • Kahlief
      Reply

      Thanks so much for commenting and i’m glad it worked. It makes me happy to share awesome info like this. Again thank you for coming by our site.

      June 2, 2014 at 11:44 am
  • Chianna
    Reply

    I am having trouble with my recordings. I got everything to work however when I go the folder its supposed to be saved in the folder is empty. Any thoughts?

    June 11, 2014 at 2:00 pm
  • connor
    Reply

    cant get it to work on titanfall red line geforce gt 630

    July 31, 2014 at 7:51 am
  • Lolopo
    Reply

    It worked on my Lenovo Y510P. Thnaks guys. Now i can save my videos

    September 16, 2014 at 9:26 pm
  • Myrmidon
    Reply

    So I got all the way to opening shadowplay. I got the window to open and everything, but when I flip the switch, it says “Activating Shadowplay” and then it will just stop and unflip the switch itself. What’s gone wrong? In XPerience it says I meet all the requirements and I have an 840M card.

    October 1, 2014 at 10:37 am
    • KaitoX92
      Reply

      Same problem here.

      January 15, 2015 at 8:33 am
  • Rishi
    Reply

    I have laptop with below config-

    8GB RAM

    Core i5 2.67Ghz

    Geforce gt 540m

    Driver vesion – 337.88

    and I have tried the mentioned steps to enable shadow play mode but no luck. Please help

    November 21, 2014 at 2:43 am
    • Harold
      Reply

      You only have to add -shadowplay to the path do not delete all, just add this with a space. It will work cuz I had the same problem.

      January 25, 2015 at 10:56 pm
  • shitty shit
    Reply

    it’s shit ! ! ! !

    January 25, 2015 at 12:34 am
  • Jason
    Reply

    Just put -shadowplay at the end of your target location and it will work !!!

    February 1, 2015 at 12:06 am
  • Dedalus
    Reply

    Wow, it’s working on my Lenovo Ideapad Y510P :D. You’re amazing guy!

    February 1, 2015 at 8:02 am
  • John Martin
    Reply

    This worked perfectly for me! πŸ™‚

    I have a small problem though, how do i open up the original geforce experience panel? It only opens the shadowplay menu now and not the full geforce experience panel.

    February 19, 2015 at 4:15 pm
    • John Martin
      Reply

      Never mind!
      Just had to click the settings tab and everything opened up πŸ™‚

      Thanks sir. <3

      February 19, 2015 at 4:17 pm
  • chhaihy
    Reply

    Hey guy u hv to downgrade ur driver version

    November 12, 2015 at 9:43 pm
  • Tedo
    Reply

    Its not working for me, when i want to record nothing..(sorry about my english)

    November 15, 2015 at 10:55 am
  • Dragon
    Reply

    Hey, thanks for the advice on getting shadowplay to work, but I’m having a small issue of it just starting up the minimized window with the shadowplay switch and that’s it. I can’t access Geforce, and it only “activates” for a couple of seconds. Any help would be really appreciated. Thanks.

    December 7, 2015 at 4:33 pm
  • egecagdas
    Reply

    I can’t flip the switch on, the screen flickers a little but nothing happens at all. Can somebody help me? I have 630m and i saw someone could manage to make it work.. pls help.

    March 24, 2016 at 11:35 am
  • Midi
    Reply

    I’m flipping the switch in ShadowPlay and it says it’s activating, but nothing happens. It just goes back to off. I see there are a few people in these comments with the same problem, but no solution has been offered to either of them. Has anyone figured out why this is happening?

    February 8, 2017 at 3:31 pm
  • Midi
    Reply

    Yooooo I just figured out how to make the activation switch work lol. This youtube vid’s solution worked for me! https://www.youtube.com/watch?v=8J3yXXWtQwQ

    February 8, 2017 at 3:38 pm
  • is shadowplay also work on GForce 820M? or its only for GTX series?

    February 13, 2017 at 2:34 am
    • Won’t work only GTX series (GTX600 and above) sadly. I’ve tried.

      February 18, 2017 at 3:22 pm

Speak your Mind